Jump to content

Input? P1516


03SSrado

Recommended Posts

My 2003 Sss has always been great friends with the Low Fuel light but now is starting to hang out with the check engine light too much. Truck keeps going into protect mode, or reduced engine power.. Its throwing the code p1516 and that looks like its gonna be Throttle Actuator control. Local autoparts stores dont carry them, guess thats a factory part? anyone have tricks to fixin this or getting one?

 

thanks guys.

Link to comment
Share on other sites

I have never heard of that before, but I do know that running the truck super low on gas all the time is really bad for many parts :ph34r:

 

 

yeah i know i was jokin around, gas prices just keep on goin up.. umm i looked it up and its sayin throttle actuator control. guessin this takes place of an actual throttle cable since these are electronic??

Link to comment
Share on other sites

this code is usually a result of a miss match between the commanded throttle position and the actual.

 

Check to make sure you don't have carbon build up on your TB, or that it is binding/jamming. Also check all your connections for loose wires between your gas peddle, TAC module and the TB

Link to comment
Share on other sites

this code is usually a result of a miss match between the commanded throttle position and the actual.

 

Check to make sure you don't have carbon build up on your TB, or that it is binding/jamming. Also check all your connections for loose wires between your gas peddle, TAC module and the TB

 

 

i will definitely check that. so if all connections are good just clean TB... thanks for the tips

Link to comment
Share on other sites

will do, just got her in the garage, turned on the heat and about to start searchin for the problem and clean the TB.

while on this topic, P0455 is an emissions code, would this be CAT? or 02 sensor?

My truck threw those codes a few weeks ago...after some informal reasearch I found out it could be a few things...but not limited to...

bad wiring at throtle control...(dealer sells a repair harness)

low voltage at start up...

Link to comment
Share on other sites

P0455 is an emissions code, would this be CAT? or 02 sensor?

 

That is an EVAP code which stands for a large EVAP leak. Check your gas cap, make sure it is tight.....if the light does not go away after a few days, or comes back after being reset with a scan tool, further testing will be needed in order to find a blockage or faulty valve in the EVAP system......

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...