Jump to content

Need Help


Recommended Posts

I installed a OEM Nav radio in my 2004 silverado out of a 06 Hummer, along with XM and a 6 CD changer. Everything works with the exception of the CD changer. The head unit sees the XM and you can control from the touch screen. The 6 pack with power up and load and unload, but the radio does not see or control it, and I cannot select with the band button. Anyone have any info on what I should do to fix?

Link to comment
Share on other sites

looks like you need you TNR programmed to recognise the slave unit. I am in the process of doing the same with a twist. I will let you know how to fix it once I get it done.

 

Sent from my thunderbolt using Tapatalk

 

 

Thanks, looking forward to hearing what you did

Link to comment
Share on other sites

  • 4 weeks later...

Can ANYONE help me with this problem, the truck just spent a full week at the gm dealership and they could not get the head unit to see or control the 6 cd changer. They say they could not program the BCM to see the new part number of the 06 hummer head unit. Pulling my hair out in Ohio.

Link to comment
Share on other sites

I lost this thread and couldn't find it, weird. anyways, I finally got around to installing my CDX and had the same problem. it turned out that pin 14, the class 2 data bus, pin was loose in my harness and game me hell. Everything as you discribed. With the help of my brother, we diagnosed the faulty connection at the cdx. The pin was opened beyond contact and would not make a proper connection. We ended up pulling the pin out, and re-bending the contacs so that it would engage the CDX properly. After that, everything worked flawless. Also, if all is good, you might need to pull the radio fuses for about 10 seconds so that the TNR resets, and see's the CDX.

Link to comment
Share on other sites

Also did you make sure that you got the proper CDX. the one needed is the one with metal tabs, not plastic slides. IF you have the one with plastic slides it will not work even thought it plugs in

 

 

 

 

Thanks for the info, yep I bought one and thought maybe it was bad, so I bought a refurbished one from a stereo dealer and they both acted the same way, I even changed out the cable going to the cdx to ensure that I had not messed it up, have not pulled the stereo fuse yet, but disconnected the truck battery for 30 mins to reset everthing, still no joy. Both of the CDX were out of a 2004 Tahoe. Headed out now to pull the stereo fuse, will let you know if it works. Nope didn't work, still thanks for all the info

Edited by truck454 (see edit history)
Link to comment
Share on other sites

there is nothing more irritaing than a plug-n-play mod that wont work. Where are you getting your class 2 data bus source from?

 

 

I picked it up from the data bus in/out from the 24pin plug going into the radio, is there a better source? Any help or ideas are welcome.

Link to comment
Share on other sites

I picked it up from the data bus in/out from the 24pin plug going into the radio, is there a better source? Any help or ideas are welcome.

 

 

 

 

Double check your connection, and the pin number that you hooked up to. All of your symptoms indicate that the CDX is not communicating on the class 2 databuss

Link to comment
Share on other sites

  • 2 weeks later...

Double check your connection, and the pin number that you hooked up to. All of your symptoms indicate that the CDX is not communicating on the class 2 databuss

 

 

have read out from pin to pin all is ok, I finally broke down and took back to a gm dealer, they worked on it for 2 hours and finally told me that the upgrade is not supported and they could not do anything without a vcim (vicm) (whatever) number and then they charged me 46 dollars to let me have the truck back and told me good luck and to let them know if I ever get the system fixed. Anyone know what a vcim number is and where would I get it. losing my mind here in ne ohio.

Link to comment
Share on other sites

have read out from pin to pin all is ok, I finally broke down and took back to a gm dealer, they worked on it for 2 hours and finally told me that the upgrade is not supported and they could not do anything without a vcim (vicm) (whatever) number and then they charged me 46 dollars to let me have the truck back and told me good luck and to let them know if I ever get the system fixed. Anyone know what a vcim number is and where would I get it. losing my mind here in ne ohio.

 

 

You still havent told me which pin you got the class II data bus from... In my case, the class II data pin on the CDX end of the harness was loose, it was loose because somehow the pin got "stretched out" and wold not make contact with the CDX end. once I figured it out, I pulled the pin out of the harness, and re-bent the contacts with in the pin. This fixed everything for me.

Link to comment
Share on other sites

You still havent told me which pin you got the class II data bus from... In my case, the class II data pin on the CDX end of the harness was loose, it was loose because somehow the pin got "stretched out" and wold not make contact with the CDX end. once I figured it out, I pulled the pin out of the harness, and re-bent the contacts with in the pin. This fixed everything for me.

 

 

I picked it up from A1 of the 24 pin plug coming into the back of the radio

Link to comment
Share on other sites

Damn, I have no more ideas, It would be nice if you where closer so that we can do full diagnostic but that is out.

 

 

Thanks for all your thoughts on it, I guess I will just sale the entire package, nav radio, xm, and 6 cdx and go with aftermarket stuff. will let everyone know how that turns out.

Edited by truck454 (see edit history)
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...